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Chapter 11: Printing 

Introduction 
TOPS Pro provides a lot of flexibility in the way you design and print 
analysis output.  When you've completed an analysis and decided on a 
solution, TOPS Pro allows you to print a hard copy of the information that 
went into the analysis.  For a package profile, TOPS Pro allows you to 
print a pre-defined report. 

This chapter walks you through the following print features and functions: 

 Print Preview for an analysis, including how to define print parameters 
 Print Preview for a package profile 
 Add text to Print Preview 
 Add a graphic image to Print Preview 
 Edit a graphic image in Print Preview 
 The Quick Print feature 
 The Combined Report feature 
 Printer width 

Print Preview – Analysis 
After you’ve selected a solution for an analysis, you're ready to print the 
output of that analysis.  This section explains how to design the layout of 
the printout, then define the type of information to be included and how 
present that information (different graphical views, text and numbers, 
etc.). 

In this example, we'll design the printed output to have the following 
characteristics: 

 The output will have a Quad Split page layout. 

 The heading will read "TOPS Engineering". 

 The four areas of the printout will show graphics of the Case 3D View, 
the Unitload Plan View, the UnitLoad Dual Plan and the Vehicle 3D 
View. 

 The bottom of the printout will show sample text. 
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To print the output from an analysis, start from the Control Panel and 
follow these instructions: 

1. Go to the Menu Bar and open the File menu. 

2. Select Print Preview, then select Analysis. The Print Parameters dialog 
box appears. 

Define Print Parameters 
The Print Parameters dialog box, pictured below, allows you to design the 
layout of the output, what type of information will be included, etc. 
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The Print Parameters dialog box is organized into the following sections: 

 Page Layout:  Allows you to select one of 11 possible page layouts: 

 The Full Page layout allows you to select only one area of the 
analysis to print. 

 The Horizontal Split and Vertical Split layouts allow you to 
select two areas of the analysis to print. 

 The 3 Way Bottom, 3 Way Top, 3 Way Left and 3 Way Right 
layouts allow you to select three areas of the analysis to print. 

 The Quad Split layout allows you to select four areas of the 
analysis to print. 

 The 5 Way layout allows you to select five areas of the analysis 
 The 6 Way Fixed layout has all six areas of the analysis fixed to 

the same size. 
 The 6 Way Scaled layout has 3 different sized areas. Area 1 and 2 

are the smallest all the way up to 5 and 6 which are the largest. 
 The 6 Way Down layout has 3 small areas, 2 medium areas and 1 

long area. 
 

 Heading:  Allows you to enter the text of the heading that will appear 
at the top of the printout. 

 Areas 1 through 6:  Allow you to select the area(s) of the analysis 
from which you want to print information. 

Note:  Be aware that the number of areas available to select from 
depends on the page layout you selected.  For example, if you selected 
the Horizontal Split layout, which contains two sections, you'll be able 
to select from only two areas. 

 Notes:  Allows you to enter the text of any notes that will appear at the 
bottom of the printout. 

Tip:  To force the text to wrap to the next line, type a left apostrophe 
(`) at the end of the line of text.  In a normal word processor 
application, you'd use the Enter or Return key to do this. 

 Show Additional Notes:   Allows you to enter information about such 
as Label Format, Test Weight and Package Quantity. 

 Printer:  Allows you to select either Black and White (B+W) or Color 
printing. 

Note:  Black-and-white printing is basically a line drawing, while 
color printing is a 3-D shaded halftone. 

 Double Stack Unitload:  Allows you to print output as a double-
stacked unitload. 
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 Print Analysis Name:  Allows you to print the analysis name on the 
printout. 

 Show Graphics/C.A.S.Y.:  Allows you to show graphics or CASY 
design in the printout. 
 
Note:  If the analysis includes both graphics and a CASY design, the 
system will display the CASY design, not both. 

 Font: Here you can select the font on the preview screen. The text can 
be displayed in the following 3 sizes. 

 Regular:  Helvetica  10 pt. 
 Small:   Helvetica    8 pt.  
 Very Small:  Helvetica    6 pt. 
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Print Report Example 
To define print parameters for your analysis output, start from the Print 
Parameters dialog box and follow these instructions: 

1. Use the following fields to enter print parameters. Use the Tab key to 
move from field to field.  For the purpose of this example, we'll enter 
the following parameters 

 Page Layout:  Select Quad Split. 
 Heading:  Enter "TOPS Engineering" 
 Area 1:  Select Case 3D View. 
 Area 2:  Select UnitLoad Plan View. 
 Area 3:  Select UnitLoad Dual Plan. 
 Area 4:  Select Vehicle 3D View 

 
2. After completing the print parameters, click on OK. 
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Notice the following things about the Print Preview panel: 

 This zoom-out state is a rough approximation of the actual printout.  
For a more accurate view, zoom in. 

 The analysis name appears in the top, center of the printout and reads 
"Sample Data 1." 

 The heading appears in the top, left of the printout and reads "TOPS 
Engineering". 

 The date appears in the top, right of the printout.  TOPS Pro 
automatically inserts both the date printed and the date modified. 

Note:  At this time, there is no way to exclude the date, user name or 
page number from the printout. 

 Area 1 displays a graphic of the Case 3D View. 

 Area 2 displays a graphic of the UnitLoad Plan View. 

 Area 3 displays a graphic of the UnitLoad Dual Plan. 

 Area 4 displays a graphic of the Vehicle 3D View. 

 The Zoom button allows you to magnify the panel and get a closer, 
more detailed look at the output.  Zoom also allows you to annotate 
your printout.  For more information, please refer to page 11.9. 

 The Print button sends the output to the printer. 

 The Email button opens your mail application and attaches a standard 
printout  as a (.jpg) to be Emailed directly to another person. 

Note:  For more information, please refer to Chapter 2, The Basics. 
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Print Preview – Package Profile 
For a package profile, TOPS Pro allows you to print a pre-defined report.  
To display the Print Preview for a package profile, start from the Control 
Panel and follow these instructions: 

1. Go to the Menu Bar and open the File menu. 

2. Select Print Preview, then select Package Profile.  The Package Profile 
dialog box appears, as pictured below. 
 

 

3. Use the following fields to enter package profile parameters.  Use the 
Tab key to move from field to field.  For the purpose of this example, 
we'll enter the following parameters: 

 Pallet Spec:  Enter the specification number for the pallet style.  
By default, TOPS Pro suggests a unique spec ID. 

 Description:  Enter a description of the package profile being 
created. 

 Date:  Enter the current date to specify when the package profile 
was created. 

 Product Name:  Use the drop-down list to select a product name 
associated with the package profile or type in the first few letters of 
the product. 

Note:  The drop-down list displays products that have been added 
to this profile.  You'll use this field to edit or delete a product. 
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 Master Number:  Enter the master number associated with the 
package profile. 

Note:  You can use this field for any numeric value.  To rename 
the field, use the Text Modification dialog box.  Please refer to 
Appendix B, Dialog Boxes. 

 Clamp Direction:  Use the drop-down list to select the clamp 
direction associated with the package profile. 

Note:  The printout will show clampability arrows on the unitload 
according to your input here.  Unlike the clampable option on the 
UnitLoad Options dialog box, the clamp direction does not affect 
the calculations. 

 Cube Stacking Count:  Enter the maximum stacking height for 
your warehouse. 

Note:  Like the Master Number field, you can use this field for any 
numeric value. 

 Comments:  Enter the text of any comments that are relevant to 
the package profile. 

4. After completing the package profile parameters, click on OK.  The 
Print Preview panel appears, as pictured below. 
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Notice the following things about the Print Preview panel: 

 The pallet specification number, description, date created and 
master number appear in the top of the printout.  These items 
match the information you entered on the Package Profile dialog 
box. 

 A series of pallet statistics appears in the top, left of the printout. 

 The Products section displays a variety of information about the 
products included in the package profile. 

 A number of graphic views appear in the bottom and left portions 
of the panel. 

 The Comments area displays any comments you entered on the 
Package Profile dialog box. 

 The Zoom button allows you to magnify the panel and get a 
closer, more detailed look at the output. 

 The Print button sends the output to the printer. 

5. To print the output, click on the Print button.  The system sends the 
print preview output to the printer. 

Annotate a Printout with Text 
After you've designed and generated your analysis output, the system 
allows you to annotate a printout with text before you print it.  This allows 
you to customize and enhance the output's presentation. 

To add text to the output, start from the Print Preview panel and follow 
these instructions: 

1. Click on the Zoom button. The system magnifies the Print Preview 
panel. 

2. Click on the area of the output where you want to enter text.  The 
system displays a four-cornered entry field with the cursor positioned 
inside the field.  Notice that you can "drag" the entry field to any 
position on the screen. 
 
Note:  To make copies, hold down the Control key (Ctrl) while 
dragging. 

3. Enter the text that you want to appear in the selected area.  In this 
exercise, enter text as follows: 
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 In Area 1 (top left), click above the graphic and enter this text:  
"UnitLoad 3D View." 

 In Area 2 (bottom left), click above the graphic and enter this text:  
"UnitLoad Plan View."  

 In Area 3 (bottom right), click above the graphic and enter this 
text:  "UnitLoad Statistics." 

4. To change the font and/or font size, open the Text menu and select 
Font.  The Font dialog box appears, as pictured below. 
 
Note:  At this time, you cannot mix fonts within a single annotation. 
 

 

5. Use the Font dialog box to select the font, font style and/or size and 
click on OK.  TOPS Pro returns you to the Print Preview panel. 

6. Drag the text fields so they're positioned where you want them. 

7. After adding the text, click on the Print button. The system sends the 
analysis output to the printer. 
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Insert Arrows on a Printout 
From time to time, you might want to enhance a printout with some well-
placed arrows.  In TOPS Pro, inserting an arrow on a printout involves a 
little-known keyboard trick – using the Alt key and the numeric keypad to 
insert keystrokes that are not usually available.  This method offers an 
advantage over using bitmaps – these arrows have transparent 
backgrounds and won't obliterate the area on the printout where they're 
placed. 

Most fonts have more symbols than the normal 26 letters, 10 numbers and 
punctuation symbols.  A font often includes arrows, trademark symbols, 
accented characters, etc.  In Microsoft Word, if you open the Insert menu 
and select Symbol, the Symbol dialog box appears, as pictured below.  
You can also use the Windows Character Map feature, located in the 
Accessories folder. 
 

 

If you highlight a symbol – such as the right arrow (→) – a number 
appears on the status bar; for example, 174.  This number represents the 
ASCII code for the selected symbol and the selected font. 

The following steps allow you to insert these characters into most 
programs, even if they don't have an Insert Symbol feature.  To insert 
characters into a TOPS Pro printout, follow these instructions: 

1. Go to the Print Preview Screen and zoom in. 

2. Click on the screen to insert text. 

3. Make sure the keyboard's Num Lock light is on. 
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4. Open the Text menu and select Font to display the Font dialog box. 

5. Select the font you want to use.  
 
Note:  To insert arrows onto the printout, use the Symbol or 
Wingdings font.  To simply bold or italicize the text, use the active 
font should be sufficient. 

6. Hold down the Alt key on your keyboard. 

7. While holding down the Alt key, type the ASCII number for the 
symbol you want to insert with a zero (0) in front; for example, type 
0172.  Use the table below as a guide. 

8. Release the Alt key.  TOPS Pro inserts the selected symbol onto the 
printout.  You may need to adjust the font size to make it more legible. 

 

Common ASCII Codes for Symbols 

Symbol Font Wingdings Font 

0171   ↔ 0219   ⇔ 0223    0231    0239    

0172   ← 0220   ⇐ 0224    0232    0240    

0173   ↑ 0221   ⇑ 0225    0233    0241    

0174   → 0222   ⇒ 0226    0234    0242    

0175   ↓ 0223   ⇓ 0227    0235    0245    

1076   ° 0226   ® 0228    0236    0246    

 0227   © 0229    0237    0247    

 0228   ™ 0230    0238    0248    
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Annotate a Printout with Graphics 
After you've designed and generated your analysis output, the system 
allows you to add text to the output before you print it.  This allows you to 
customize and enhance the output's presentation. 

To add a graphic image to the output, start from the Print Preview panel 
and follow these instructions: 

1. Go to the Menu Bar and open the Edit Menu. 

2. Select Paste Pic From File.  The Select File dialog box appears, as 
pictured below. 
 

 
 
Notice that this dialog box displays a list of bitmap files. 

3. Select the tops.bmp file and click on OK.  The Print Preview panel 
redisplays with the selected TOPS Pro bitmap file inserted into the 
output. 

4. Drag the image to the area where you want it to appear. 

5. Open the Edit menu and select Paste. 

6. System Response:  Windows copies the image from the clipboard and 
pastes it to the output. 

7. After adding the graphic, click on the Print button.  The system sends 
the analysis output to the printer. 
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Tips for Working with Graphics 
When you're using graphics to annotate a printout, keep these tips in mind: 

 Graphics are resizable.  To resize a graphic image, press the Control 
key and use the corner tabs to drag and resize the graphic.  The 
Control key allows you to resize the graphic – wider, thinner, shorter, 
taller – without distorting the image proportions. 

 To make copies of a graphic image, hold down the Ctrl key and move 
the image from one point to another. 

 To restore a graphic image to its original size, follow these 
instructions: 

1. Click on the image. 

2. Open the Picture menu and select Restore Size. 

 To edit bitmap images, follow these instructions: 

1. Double-click on the image.  The Windows Paintbrush application 
opens with the selected image ready to be edited. 

2. Use Paintbrush to make any necessary edits to the graphic image. 

3. Save your work in Paintbrush and close the Paintbrush application.  
TOPS Pro returns you to the Print Preview panel in Zoom mode.  
The edited graphic has been inserted in its original area of the 
panel.  The graphic has a tab on each corner that allows you to 
resize the image, if necessary. 

4. Open the Edit menu and select Refresh. 

5. If the edited graphic is correct, click on the Print button. 
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Edit a Graphic Image in Print Preview 
You might decide to edit a graphic image before you print the output.  To 
edit a graphic image in Print Preview, start from the Print Preview panel 
and follow these instructions: 

1. Click on the Zoom button. 

2. Right-click on the graphic you want to edit.  A dialog box appears and 
asks if you want to convert the graphic to a bitmap. 

3. Click on Yes.  The Save File As dialog box appears, as pictured below, 
and prompts you to enter a file name for the graphic. 
 

 
 

4. Enter a file name for the graphic and click on OK. 

5. Edit and resize the graphic image using the instructions outlined on 
page 11-14 in the previous section, Tips for Working with Graphics. 

6. When the edited graphic is the way you want it, click on the Print 
button. 
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Quick Print 
The Quick Print feature allows you to create and use a standardized 
printing template and print output for an analysis, based on the selected 
template.  This feature allows you to print output for an analysis without 
manually defining parameters on the Print Parameters dialog box. 

To print output using the Quick Print feature, start from the Analysis View 
and follow these instructions: 

1. Click on the QPrint button.  The Quick Print dialog box appears, as 
pictured below. 
 

 
 

2. Select the template you want to use to print the analysis. 
 
Note:  The window contains a list of standardized printing templates.  
Each template has a standard print output coded for it.  This feature 
allows you to print output for an analysis without manually defining 
parameters on the Print Parameters dialog box.  For information about 
creating Quick Print templates, please refer to Chapter 15, Supervisor 
Functions. 

3. Use the following fields to enter Quick Print parameters.  Use the Tab 
key to move from field to field.   

 Send To:  Select an option – PDF, Printer or Both – to specify a 
print destination. 

 Include:  Select one or more options – Analysis, Pallet Spec, 
Statistics, Problem Def – to specify what will be included in the 
printout. 
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 Heading:  Enter the text of the heading that will appear at the top 
of the printout. 

 Notes:  Enter the text of any notes that will appear at the bottom of 
the printout. 

 PDF:  If you select PDF or Both in the Send To field, use the 
Browse button to select a PDF file to print to. 

Note:  This option is integrated with and requires the Adobe 
Acrobat software product.  Without Acrobat, the PDF option will 
not work. 

4. After completing the Quick Print parameters, click on OK. 

Combined Report: Compare Analysis 
The combined report function places any two analyses side-by-side for 
comparison. Users can specify which sequence of the analysis 
(intermediate pack, shipcase or unitload) to appear in the report. To create 
a combined report: 
 
1. Open the first analysis you’d like to use. 

2. Click the Combined Report button  on the tool bar or go to the File 
Menu on the Tool Bar, select Print Preview and then Combined Report 
to specify the second analysis. 
 

     

 Analysis:  Click the Browse button to select a second analysis to 
compare. 

 Sequence:  Select from the drop down list box the sequence to 
appear in the report. 
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3. Upon selection of the above parameters, click OK and the combined 
report will appear in the preview screen as shown below.  

4. Users can choose to edit, zoom, print or email from the analysis 
preview. 

 

Note: The Combined Report offers a convenient way to compare analyses 
of the same items being loaded onto different pallets. 
 

 
Combined Report for Knocked-Down and Erected 
Boxes 
Users can use the combined report to include both knocked-down and 
erected palletizations of a shipcase.   

To use the Combined Report feature for this purpose, both analyses must 
have the same name – with one exception.  At the end of the erected 
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analyses name, put "{Box}" and at the end of the knocked-down analyses 
name, put "{KD}"; for example, Sample{Box} and Sample{KD}.   

Note:  If the analysis has been saved with one of those two tags in the 
name, a button (Knockdown/Box) appears on the Control Panel button bar 
to facilitate switching/creating the two analyses.  (Note that this feature is 
not available to Loadstack licensees.) 

To access this special Combined Report feature, follow these instructions: 

1. Correctly name the analyses, using the guidelines above. 

2. Use one of two options: 

 Open the File menu, select Print, then select Combined Report. 
 Open the File menu, select Print Preview, then select Combined 

Report. 
The Combined Report Print Preview panel appears. 

3. Annotate or add graphics as necessary. 

4. After completing the annotations or graphics, click on Print.  TOPS 
Pro sends the Combined Report to the printer. 

If you need assistance, contact TOPS Technical Support. 
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Combined Report: Compare Solution 
At any stage of an analysis (shipcase, pallet load or container), you can 
create a side-by-side comparison report between any two solutions.  To 
create a combined report for solution comparison, follow these steps: 

1. Open the analysis you’d like to use. 
 

 
 
In the analysis illustrated above, solution 4 is the current shipcase 
solution (Shipcase View 1 of 4).  We will create a combined report of 
this solution to say, solution 4.   

2. Bring the mouse cursor to solution 4 in the Solution List Pane and 
click the right mouse button. 

3. At the pop up dialog, select “ Preview Multiple Solution ”. 

4. The report preview screen, as shown on the next page, will open. 
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You can choose to edit, zoom, print and email from the preview. 
 
Note: Users can perform comparisons for the unitload or vehicle solutions 
in a similar fashion. 
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Printer Width 
The printer width refers to the thickness of the lines in a graphic or text 
when you print an analysis.  The default for printer width is zero, which is 
a hairline width.  You might want to make the printed lines thicker; for 
example, to improve fax documents.  If so, TOPS Pro allows you to 
change the printer width in Configuration. 

Note:  If the Show Graphics feature is turned on, the printer width will 
have no effect. 

To change the printer width, follow these instructions: 

1. From the Menu Bar, open the Tools menu. 

2. Select Configuration. 

3. In the Printer Width field, enter a value to specify the line thickness 
with which you want to print.  A line thickness of 4-7 is usually a good 
width. 

4. If you're satisfied with the printer width, click on OK.  The system 
saves the updated configuration to the database and returns you to the 
previous screen. 
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