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Chapter 15: Supervisor Functions 

Introduction 
This chapter discusses the functions available to a supervisor in the TOPS 
Pro System.  Supervisor functions include the following: 

 Login/logout as a supervisor 
 Change your password 
 Add a user to the system 
 Delete a user from the system 
 Rename a user in the system 
 Approve or deny an analysis 
 Set up a Quick Print template 
 Define global configuration settings 
 Rebuild files 
 Set up the way statistics are displayed in the system 
 Open and transfer other users' analyses 
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Login/Logout 
Before you can perform any of the supervisor functions in either TOPS 
Pro or the TOPS Configuration program, you have to login as a 
supervisor.  Start from the Menu Bar and follow these instructions: 

1. Open the Supervisor menu. 

2. Select Login/Logout.  The Supervisor Login dialog box appears, as 
pictured below. 
 

 

3. Enter the supervisor password. 

Note:  The default password is "tops software".  Note the space 
between "tops" and "software". 

4. Click on the Login button.  TOPS Pro logs you into the system as a 
supervisor. 

5. To logout of the system once you have logged in, click on the Logout 
button and TOPS Pro will log you out of the Configuration program. 
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Change Password 
Once you're logged in as a supervisor, you can change the login password 
if you want.  To change the password, start from the Supervisor Login 
dialog box and follow these instructions: 

1. Click on the Change Password button.  The Supervisor Login dialog 
box redisplays, as pictured below. 
 

 

2. Enter the old password in the first Password field. 

3. Enter the new password in the second Password field. 

4. Click on the Change button.  The Confirm Password dialog box 
appears, as pictured below. 
 

 

5. Enter the new password in the Password field. 

6. Click on OK and TOPS Pro changes the password and issues a 
message to this effect. 
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Logoff a User 
This function allows you to logoff a user from the system, which is critical 
for network users who have a limited number of TOPS Pro software 
licenses.  For example, if you have two licenses and two users are logged 
on, then a third user will not be able to logon until one of the current users 
logs off. 

You may find it necessary to logoff someone if he or she logged onto 
TOPS Pro, then did not exit the system normally (e.g., in the event of a 
crash or power failure).  Use these guidelines: 

 If you're unable to enter TOPS Pro to logoff a missing user, you can 
always login as that user, replace that user, then exit. 

 If passwords are enabled, the supervisor password grants access to 
users. 

 You can also logoff users from the TOPS Configuration program. 

To logoff a user from the system, start from the Menu Bar and follow 
these instructions: 

1. Use one of two options: 

 In the TOPS Pro system, open the Tools menu. 

 In the TOPS Configuration program, open the File menu. 

2. Select User List.  The User List dialog box appears, as pictured below. 
 

 
 
The User List dialog box displays all users currently logged onto the 
system.  The list above contains one user, but there can be as many 
users as there are purchased TOPS Pro software licenses. 
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3. Select the user you want to log out of the system. 

4. Click on the Logout button.  TOPS Pro asks if you're sure you want to 
log the user out of the system. 

5. Click on the Logout button.  The User List dialog box redisplays with 
an updated list of users logged onto the system.  The user you just 
logged out is deleted from the list. 

Add a User to the System 
To add a user to the system, you have to Login as Supervisor.  Start from 
the Menu Bar and follow these instructions: 

1. Open the File menu. 

2. Select User Login.  The User Login dialog box appears, as pictured 
below. 
 

 

3. Click on the Add User button.  The New User dialog box appears, as 
pictured below. 
 

 

4. Enter the name of the user you want to add to the system. 

5. Click on OK.  The User Login dialog box redisplays with the new user 
added to the user list. 

Note:  At this time, there is no way to prevent any user from adding a user 
to the system. 
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Delete a User from the System 
To delete a user from the system, start from the Menu Bar and follow 
these instructions: 

1. Open the File menu. 

2. Select User Login.  The User Login dialog box appears, as pictured 
below. 
 

 

3. Click on the Delete User button.  TOPS Pro asks if you want to delete 
all analyses that belong to the selected user. 

4. Click on Yes.  The User Login dialog box redisplays with the selected 
user deleted from the user list. 

Rename a User in the System 
To rename a user in the system, start from the Menu Bar and follow these 
instructions: 

1. Open the File menu. 

2. Select User Login.  The User Login dialog box appears. 
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3. Click on the Rename User button.  The New User dialog box appears, 
as pictured below. 
 

 

4. Enter the new (edited) name of the user you want to rename in the 
system. 

5. Click on OK.  The User Login dialog box redisplays with the selected 
user renamed in the user list. 

Approve an Analysis 
When a user performs an analysis and saves it to the database, he or she 
will request approval for that analysis with the Request Approval option 
on the File menu.  TOPS Pro takes that request for approval and places it 
in a queue of analyses waiting to be approved or denied by a supervisor.   

To approve an analysis, start from the Menu Bar and follow these 
instructions: 

1. Open the Supervisor menu. 

2. Select Open Request.  The Open Request for Approval dialog box 
appears, as pictured below. 
 

 

3. Select an analysis you want to examine for approval or denial. 

4. Click on OK.  TOPS Pro opens the selected analysis in the Analysis 
View. 
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5. Examine the analysis to decide if you want to approve or deny it. 

6. To approve the analysis, open the Supervisor menu. 

7. Select Approve.  TOPS Pro asks if you want to approve the selected 
analysis. 

8. Click on OK.  TOPS Pro moves the analysis from the Request 
Approval queue and into the Approved portion of the database.   

Note:  If you look at the Open Analysis dialog box, you'll see the selected 
analysis listed in the Approved section of the analysis list. 

Deny Approval of an Analysis 
When a user performs an analysis and saves it to the database, he or she 
will request approval for that analysis with the Request Approval option 
on the File menu.  TOPS Pro takes that request for approval and places it 
in a queue of analyses waiting to be approved or denied by a supervisor.   

To deny approval of an analysis, start from the Menu Bar and follow these 
instructions: 

1. Open the Supervisor menu. 

2. Select Open Request.  The Open Request for Approval dialog box 
appears, as pictured below. 
 

 

3. Select an analysis you want to examine for approval or denial. 

4. Click on OK.  TOPS Pro opens the selected analysis in the Analysis 
View. 

5. Examine the analysis to decide if you want to approve or deny it. 

6. To deny approval of the analysis, open the Supervisor menu. 
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7. Select Deny Approval. TOPS Pro asks if you want to deny approval of 
the selected analysis. 

8. Click on OK.  TOPS Pro removes the analysis from the Request 
Approval queue. 

Set Up a Quick Print Template 
As you work with TOPS Pro day-to-day, you'll find that you perform and 
print some analyses on a frequent basis.  TOPS Pro allows you to setup a 
Quick Print template for these routine printouts.  Instead of manually 
setting up print parameters, Quick Print builds the printout automatically. 

Note:  TOPS Engineering can customize each of these templates for you, 
or you can create your own templates from scratch.  For more information 
about the Quick Print function, please refer to Chapter 11, Printing. 

To set up a Quick Print template, start from the Menu Bar: 

1. Open the Supervisor menu. 

2. Select QPrint Template.  The Control Panel displays in red. 

Note:  You are now in "edit template" mode, which allows you to 
open, save and change templates. 

3. Perform the analysis for which you want to set up a Quick Print 
template. 

4. Open the File menu. 

5. Select Print Preview, then select Analysis.  The Print Parameters 
dialog box appears. 

6. Use the Print Parameters dialog box to set up template print 
parameters. 

7. Click on OK.  The Print Preview Screen appears. 

8. Use the Print Preview Screen to add any annotations or graphics. 

9. Save the Quick Print template to the database. 

10. Click on OK.  TOPS Pro returns you to the Control Panel 

11. Click on the Return button.  The Control Panel redisplays in its normal 
colors. 
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Global Configuration 
In the TOPS Configuration program, a supervisor can select and de-select 
a number of configuration options that are not available in the TOPS Pro 
for Windows program or to anyone other than a supervisor.  This function 
allows you to define a global configuration for your TOPS Pro system.   

To define a global configuration, start from the TOPS Configuration 
program and follow these instructions: 

1. Open the Supervisor menu. 

2. Select Global Configuration.  The Global Configuration dialog box 
appears, as pictured below. 
 

 

Notice that this dialog box is organized into two sections. 

 Top Section:  The top section displays Configuration settings that are 
primarily affect the way TOPS Pro displays information on a user's 
screen – for example, whether or not to display specific dimensions, 
flaps on cartons, the g.o.d. window, etc.  If you change these settings, 
the Configuration changes will take effect for all new users in the 
system.  The changes will not affect users already set up in the system. 
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 Bottom Section:  The bottom section displays Configuration settings 
that affect how the TOPS Pro software runs – for example, whether or 
not to allow users to approve their own analyses, to allow duplicate 
products in a Package Profile or to turn on the Artios-Laserpoint IQ 
interface.  These parameters affect all existing and/or new users.  Be 
aware that if you change these parameters, in order for the changes to 
"stick," all users in TOPS Pro and TOPS Configuration must exit the 
respective systems. 

For detailed information about the Global Configuration dialog box, 
please refer to Appendix B, Dialog Boxes. 

Rebuild Files 
The Rebuild Files function automatically rebuilds your database in the 
event of one of more corrupted files.  To rebuild files, start from the TOPS 
Configuration program and follow these instructions: 

1. Open the Supervisor menu. 

2. Select Rebuild Files.  The TOPS Configuration program rebuilds the 
files in the database. 

Set Up Statistics 
TOPS Pro allows a supervisor to set up rows and columns of statistics that 
will display in the various Statistics View panes.  This allows you to 
eliminate unnecessary data from your reports.   

You can perform this function in either the TOPS Pro and TOPS 
Configuration program.  The statistics setup affects all users.  Be aware 
that when you set up or change statistics parameters, in order for the setup 
or changes to "stick," all users in TOPS Pro and TOPS Configuration must 
exit the respective systems. 

To set up statistics, follow these instructions: 

1. Login as a supervisor. 

2. Use these guidelines: 

 In the TOPS Pro system, open the Tools menu and select 
Configuration. 
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 In the TOPS Configuration program, open the Supervisor menu 
and select Global Configuration. 

The Configuration or Global Configuration dialog box appears, 
depending on the system you're using. 

Note:  The dialog box displays a Statistics button.  If you did not login 
as a supervisor, the Statistics button would not be available. 

3. Click on the Statistics button.  The Statistics Setup dialog box appears, 
as pictured below. 

 

4. Set up rows and columns of statistics to construct the various Statistics 
View panes as you want. 

5. Click on OK.  TOPS Pro saves your statistics setup to the database. 

For detailed information about the Statistics Setup dialog box, please refer 
to Appendix B, Dialog Boxes. 
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Open and Transfer Other Users' 
Analyses 
When you login as a supervisor, TOPS Pro allows you to open and view 
all analyses for all users.  TOPS Pro also allows you to transfer an analysis 
from one user to another.  To transfer an analysis, follow these 
instructions: 

1. Login as a supervisor. 

2. Login as the user to which you want to transfer the analysis.  For 
example, if you want to transfer an analysis from Package Design to 
Purchasing, login as Purchasing. 

3. Open the analysis you want to transfer. 

4. Open the File menu and select Save As.  The Analysis Save As dialog 
box appears. 

5. Click on OK.  TOPS Pro saves the analysis to the database and in the 
process transfers the analysis from the previous user to the current 
user. 
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